logo vmapp.org

 query : Object won't align central to artboard in Illustrator I create a new file in Illustrator. 30 x 30 px. No stroke just black fill. I create a new rectangle 27 27 px I select the rectangle and

@Barnes313

Posted in: #AdobeIllustrator #Alignment

I create a new file in Illustrator. 30 x 30 px. No stroke just black fill.
I create a new rectangle 27 27 px
I select the rectangle and go to the icon align to artboard
I click to the icon Horizontal Align Center and Vertical Align Center
It moves but it does not align in the center

I do not understand. Is there anything else I have see. I am sure there is not guides, no other objects. I closed and open Illustrator and still does not center.

I have the same problem if I create a new document with any new rectangle. I do not know what else to check.

Any ideas?

10.1% popularity Vote Up Vote Down


Report

10 Comments

Sorted by latest first Latest Oldest Best

@Gloria351

@Gloria351

Hopefully the following experience helps anyone with a particularly persistent problem with not being able to paste into the center of an [adobe cc 2015] illustrator window. It's thorough and you can skip to the end if you "know" you've done "everything". It's for the googler, like me who just can't seem to figure it out the paste-centre problem in an .ai/.eps file and is currently frustrated by search results from google/yahoo/experts/duck-duck-go.

The situation:

I was using cmmd-0 or cntrl-0 to center the artboard/page within the illustrator. I was then using that cmmd-v or cntrl-v to usually just paste the item/s centered. It wasn't working. I was surprised as I almost always work very cleanly.

My problem solving:

But I went through the usual hang-ups. With the item/s selected and temporarily pasted into a new blank document (for less confusion by other objects):


I made sure my selected objects had the edges showing (menu>view>show edges - if your edges are showing already the menu will only give you the option to 'hide edges').
I made all my guides visible (menu>view>guide>show guides), and made sure they could be selected (menu>view>guide>lock guides - untick this by selecting it) for potential deleting. I had no guides to single out and delete.
I made sure I had the bounding box turned on to see what "size" the selection was 'occupying' (menu>view>show bounding box). The bounding box was not missing, or weirdly skewed beyond my desired selection (go through 4-7 for possibilities of what needs to be deleted). The bounding box only showed what I required and 'stuck to the very edges' of my desired selection. I couldn't see any stray points or type or guides to delete. But I kept going:
I had a look at the outline of my selection (menu>view>outline) to see what it contained - I didn't see anything extra I couldn't normally see, didn't want and needed to be selected/deleted. I turned preview back on.
I unlocked everything (menu>object>unlock all) and I unhid everything (menu>object>show all) - this didn't reveal anything new I needed to delete or explain a larger bounding box that what I could see. I also looked at outline again just in case I just 'unhid' something that wasn't stroked/filled, then turned preview back on.
I then zoomed right out to as far as I could go (menu>view>zoom in - repeatedly) turned on outline again (menu>view>outline) and then double checked for stray things. Nothing showed to zoom into and delete. Something a missing bounding box means there are the remnants of guideline points from guidelines I didn't fully delete or items/stray points waaay out into nowhere. I then turned preview back on (menu>view>preview) and zoomed back in to my selection (zoom tool or menu>view>zoom in repeatedly or cmmd-0/cntrl-0).
I ungrouped things and regrouped the exact set of items I wanted selected.
Then I cut those items (menu>edit>cut), selected 'everything else' i.e. the invisible problem which I couldn't physically click and select with my mouse (menu>select>all) and hit the backspace button to delete it/them if they even existed. I then pasted my selection back in (menu>edit>paste). The bounding box was still the same.


Retesting the situation:

I tried cmmd/cntrl-0 and cmmd/cntrl-v to test out my problem and compared any 'difference in placement' with the centre-align to artboard tool (panel available under menu>window>align) if it's not showing on that object-determined menu bar top thing (just above your document window).

The problem persists. Even after 'definitively' looking for and deleting something I couldn't find - I still can't paste at the exact center of the artboard without realigning it (by cmmd-0 then cmmd-v / cntrl-0 then cntrl-v). I googled for forums like this. No help. I had already been through the above recommendations.

A key forum comment and reflection:

Hang on a second. People kept saying 'Illustrator pastes at the center of the window. It doesn't paste at the center of a document.'

And What affects the size of my window? The scroll bar. But how on earth can ...or actually... did I affect... balance that??

My discovered answer:

The scroll bar runs bottom and side-right. The rulers run top and side-left. The 'rulers' is a 'window feature' that perfectly balances the placement and size/width of the scroll-bar.




So turn on the rulers: menu>view>rulers>show rulers. Now I find my automatic paste function is back to normal. So, effectively I alter the window, and its center, every time I turn the rulers on and off. I've tested it a few times - it must be a glitch. Sometimes the rulers on/off affect the pasting, sometimes it doesn't. But it's working now. Weird.


Sorry about the lengthy thorough response, but I hope this helps your toolkit of finding/fixing the problem.

Best of luck in your graphic work. Don't bang your head into a rock - rock your creative spirit on instead. ;p

-Sunny

(P.S. I'm Australian so the whole center/centre thing isn't really my priority - I hope you got the point despite the inconsistencies and that something helped).

10% popularity Vote Up Vote Down


Report

@Chiappetta793

@Chiappetta793

just by aligning vertically and horizontally but make sure you have aligned to artboard not to selection

10% popularity Vote Up Vote Down


Report

@Berryessa866

@Berryessa866

Windows → Align → More Options → Align to Artboard

You're currently aligning with Selection, that's the issue.

10% popularity Vote Up Vote Down


Report

@Eichhorn212

@Eichhorn212

I had the same problem completely randomly. I resolved it by checking 'use preview bounds'

10% popularity Vote Up Vote Down


Report

@Ann6370331

@Ann6370331

You need to see whether in the Align option - down right hand corner - under 'Align to section' - need to select 'Align to artboard option', then it will work properly

10% popularity Vote Up Vote Down


Report

@Margaret771

@Margaret771

It was the hidden "Guides", they got grouped to the object(s). Unhide the guides and ungroup them from your object(s), and then try to align again.

10% popularity Vote Up Vote Down


Report

@XinRu324

@XinRu324

I'm having the same problem. But it was a different issue for me. I have a design that was done in InDesign and exported to PDF, then reopened in Illustrator. When I try to align to artboard center horizontal and center-vertical, it would move but it would not be centered. If you try it again (from the position it just moved to), it would actually move to another location--almost like a step-and-repeat.

So I ungrouped, and a bunch of other boxes appear. I deleted those, and had to "release clipping mask", then I was able to center to the artboard, FINALLY!

You can see the steps I took below.

First image: placing art in document///
Image 2: trying to center horiz and vert///
Image 3: another attempt to center horiz and vert///
Image 4: ungroup and release clipping mask///
Image 5: Ta-daaa! Now it will center correctly.

10% popularity Vote Up Vote Down


Report

@Pierce403

@Pierce403

I've had this problem before. If its the same thing I experienced...here's your answer...Make sure that inside your transform tool, your "Scale Strokes & Effects" and "Align To Pixel Grid" boxes are UNCHECKED.

10% popularity Vote Up Vote Down


Report

@Sims5801359

@Sims5801359

The Align by default only works with more than one item selected.



If you change "Align To:" Artboard it will align the item based on the dimensions of the Artboard you are using.

10% popularity Vote Up Vote Down


Report

@Karen819

@Karen819

What you're doing should be correct but can I suggest, from seeing your screenshot I'm not sure if you're aligning properly.

Try Window > Align and then choosing these two selections I have highlighted. Just make sure you do this while your square has been selected:

10% popularity Vote Up Vote Down


Report

Back to top | Use Dark Theme